Installation problem on Yourhosting (503 service unavailable)

When developing small website for client I used git successfully for a Kirby installation to a staging subdomain, but now I’m stuck doing the same to the official site. I get a 503 service unavailable error. The standard htaccess which comes with Kirby works on staging, but not in the root…

PHP on both staging and root is 7.3.27.
I already filed an issue with the hosting provider, but they only reply via mail and that takes a few days…

What to do? Upload a zipped plainkit, unpack and then update the contents? How come that staging and root have different outcome while I can’t see any difference checking system and filesystem?

Hope someone has an answer or can take me in a direction to solve this :slight_smile:

Update :slight_smile:

After some searches I checked the /panel and because of the install option being enabled I was able to get in the panel. First by creating a new user, after successful login I pushed the account via git to the server and am able to log in the panel using my dev account.

Only thing now is: the blueprint I made for the one-pager on the home page is not picked up. Instead it shows the default blueprint. How can I change this? On the staging the blueprint is accepted…

Meanwhile the frontend still gives the 503 error…

How can I check if there is an error logged because I disabled debug on production?

Do you happen to have extra text files in the folder or do you use mixed case letters in your filenames?

HI there, @pixelliquid! A few questions:

  1. Are both the ‘staging’ and ‘production’ sites on the same, remote server?

  2. Do both the ‘staging’ and ‘production’ sites have their own domains? - e.g., the ‘staging’ site is on ‘’, and the ‘production’ site is on ‘’. Are either of the sites in a sub-directory of an existing domain? - e.g. ‘’?

  3. Do you change any settings/config at all when you copy the staging site to the production space, or do you really “just copy it all”?

Thanks guys for chiming in!

Weird stuff, really. While being busy checking if perhaps PHP versions were different - which they weren’t - I got some not-so-helpful reactions of the provider. Typical non-tech answers.

@kirbyzone indeed both staging and live site are on same server, staging in subdomain and the live site in the root. PHP versions are the same. And all files, including configs, were identical.

I switched PHP version on the root from 7.3 to 7.4, and back after half an hour or so. At first couldn’t see the PHP info page of their Plesk installation, but after some time it was reachable. I think at the same the 503 error disappeared. Can it be a temporary error when copying stuff? Sounds a bit odd.

But the error is “solved”, only thing bugging me is that I’m not sure what fixed it…