Installation - Folders not writable despite using 775

I moved our Kirby site to our production server and all the files/folders seem to have the correct permissions (775 for folders, 664 for files).

I added c::set('panel.install', true); to the config file and ran the installer but it says that the site/accounts, thumbs, content folder and assets/avatars are not writable.

I read several posts and it seems that these are the correct permissions but I’m not sure what’s going on.

Maybe the permissions are correct, but the ownership of the files/folders is not?

I uploaded the files through SFTP. Our I.T. department set up a new user account for us and the owner/group is identical.

I’ll follow up with them.

I have same problem.
Tried find public/ -type f -exec chmod 644 {} \; then find public/ -type d -exec chmod 755 {} \; also chown -R user:group . but panel is still not accesible because of

/site/accounts is not writable
The thumbs folder must be writable.
The content folder and all contained files and folders must be writable.
/assets/avatars is not writable

There are already some such issues here on the forum: