I installed the Kirby 3 Spreadsheet Plugin.
I added this to a textfield:
(spreadsheet: addresses.xlsx class: addresses)
But I get this error from the SpreadsheetReader:
The Excelsheet is just a simple table with three colums and rows.
What do I do wrong?
Seems to be a problem with the underlying library not being up to date with newer PHP versions. Needs an update.
“composer update” returns this:
Loading composer repositories with package information
Your requirements could not be resolved to an installable set of packages.
- nunomaduro/phpinsights[v1.9.0, ..., v1.14.1] require php ^7.2 -> your php version (8.0.3) does not satisfy that requirement.
- Root composer.json requires nunomaduro/phpinsights ^1.9 -> satisfiable by nunomaduro/phpinsights[v1.9.0, ..., v1.14.1].
Does it mean it requires php 7.2 or lower?
Or rather the plugin an update. But yes, you can test with PHP 7.2-
I’ve installed the current version of the kirby3-spreadsheet-plugin from github.
I guess the dependencies of the Plugin are not uptodate, right?
If yes, this is what I’ve tried to solve with “composer update” in “\site\plugins\kirby3-spreadsheet”.
(I prefer not to downgrade php, why should I?).
Exactly, the warning is thrown in a dependency.
But that dependency is not really needed, you can remove it
Aha, thanks for that hint
Now the update worked but I still have the same error when running the plugin.
What did I do wrong?
Hi everyone, I ran into the same error and wondering if someone managed to find a solution? Would be super usefull.