'hide: true' does not work on blueprint page settings

Hi! I am creating a custom widget for a database and a database setting page to allow the user to change the database credentials dynamically. The database setting page should be hidden in the panel, I used ‘hide: true’ on my yml file but it does not work.

Any help is appreciated! Thank you.

Have you made sure that the name of the blueprint file and the name of your content file are identical? Could you post the blueprint, please.

The setting works in a current 2.5.2 Starterkit.

Yes. under content I made a database folder, inside it is a database txt. My blueprint file is named database.yml. I also tried to put the setting on my existing yml files but it does not work. I’ve already updated my kirby installation to the latest build using the kirby cli.

Does your blueprint look similar to this:

title: Error

pages: false
hide: true

Yes. http://prntscr.com/fsoqid

That’s strange, for me the error page is hidden in the pages widget and the pages view. Or do you mean “prevent access” to the page?

I want it hidden and make it appear to the widget I made as modal form. As you can see, it is not. http://prntscr.com/fsotgh :slight_smile:

Hm, I don’t know what to say. Does it work for you in a fresh Starterkit if you try to hide any of the pages?

As for my kirby installation, I installed it through plain kit using the cli I am guessing that caused it. I’ll try later, and will update you.

Have you set pages: false in your site.yml, see this issue on GitHub: https://github.com/getkirby/panel/issues/1072