Blueprint subpages hide:true not working in my blueprint

Hi there, did I miss something with the hide function of subpages in the sidebar?

The pages “hide:true” is not working. My blueprint looks like this:

title: News
pages:
  template: article
  num:
    mode: date
    field: date
  hide: true
files: false
hide: true
options:
  preview: false
  status: false
  template: false
  url: false
  delete: false
fields:
  news:
    label: News
    type:  subpagelist
    flip:  true

This option is really handy with the SubpageList Plugin (https://github.com/flokosiol/kirby-subpagelist), but it doesn’t make any sense when I can’t deactive the sublist in the sidebar. This is my actual result:

Yes, seems like this option does not work, maybe a bug. What if you use the hide option in the subpage template itself?

Edit: This is a known issue and should be fixed on the development branch: https://github.com/getkirby/panel/issues/947

Could you please test if it works when you switch to the dev branch?

Thanks for the info. I will try to find out if the development branch helps me there.

Since 2.4.1 was released last week, this is now fixed on the release.

Hide true is still not working in my blueprint. did you change something in the blueprints to hide the pages in the sidebar?

Seems it was the other hide (for a page itself) that was fixed.

I created a new issue on GitHub.

Sorry for the work, but this could really be a great feature. Thanks for the issue!!!

This issue is now fixed on the development branch.

1 Like