Extra markdown and tables in kirby 4

hi, can i use markdown extra [i used it in an old website done with kirby 2] to manage something like that (in a text-area field):

| ------------- | ------------- | ------------- |
| - | 598,61 € | 7.781,93 € |

and print something like that in frontend:

The issue is i need a flexible way to manage tables with different values, rows, and columns.
In 2016 i choose this way. Now i am updating to kirby4, but i would like to avoid a manual data entry [the website has something like 120 articles].

Please see: markdown | Kirby CMS

i saw it, but i cannot understand how to use it
i tried to configure markdown extra in my starterkit k4, but it didn’t work.

Please post what you put into your config

    'markdown' => [
        'extra' => true

That looks good, but better post the complete config

this is the code into the config.php


 * The config file is optional. It accepts a return array with config options
 * Note: Never include more than one return statement, all options go within this single return array
 * In this example, we set debugging to true, so that errors are displayed onscreen. 
 * This setting must be set to false in production.
 * All config options: https://getkirby.com/docs/reference/system/options
return [
    'debug' => true,
    'panel.install' => true,
    'markdown' => [
        'extra' => true

is a simple file because i am starting now using K4, this is a starterkit.

this is the command i am using in template:

<?= $page->test()->kirbytext() ?>

and this is the result

i realize in my old k2 site i used this code to print the content:

    <div class="something" markdown="1">
        <?= $page->content()->kirbytext() ?>

I tried to use markdown=“1” in my new website, setting up a div container with this parameter.
But it didn’t work.

Guess it has to do with this line, please try and leave a blank line between this and the table

1 Like

ok, it was the problem.
Thank you!

… or take a look at the new table plugin: