Markdown doesn´t render

Hello all,

I am currently coming to the issue that my template doesn´t
render the markdown syntax. Using Kirby: Version 3.1.3

What can I do?

Here is how I render the text:

<div><?= $page->text()->kt() ?></div>

On the screenshot you can see how the text is rendered.

Is markdown extra enabled?

Yes, i got make it to work. But still have a problem to use css classes in the markdown.
Is this possible:

#### Coinkitchen {.dark}

This doesn´t work for me.

That’s only possible if you enable Markdown Extra https://getkirby.com/docs/reference/system/options/markdown

Yes, I have enabled it in my confic, but still doesn’t work.

Any other way to use css classes? Or do I have to set something up in the blueprint?

I also cannot use columns

If I use markdown in my blueprint I always get this error: Invalid field type (“markdown”)

Could you post your config.php please?

What do you mean by setting markdown in your blueprint?

<?php

return [
    'debug' => true,
];

return [
  'markdown' => [
    'extra' => true
  ]
];



c::set('cache', false);
c::get('cache.autoclear', true);
c::set('markdown.extra', true);

My blueprint:

fields:
  text:
    type: markdown
    size: huge

That won’t work, you can only have one return statement:

<?php

return [
    'debug' => true,
    'markdown' => [
        'extra' => true
  ]
];

c::set() is no longer possible.

See docs: https://getkirby.com/docs/reference/system/options

1 Like

Thank you. Didn’t know that. But I still ge the error: Invalid field type (“markdown”).

Do i have to change something in the blueprint:

fields:
  text:
    type: markdown
    size: huge

It works now, but still doesn’t render the coloums plugin

What columns plugin? Are you using a version updated to Kirby 3?

used an older one from my previous project. Can you recommend a Coloumn PlugIn? I can’t find something that works.

1 Like

Great, that works for me. Thank you very much

Hello, I am updating from kirby 2 to kirby 3 but I am stuck on " Invalid field type (“markdown”)" in the panel, I don’t know how to go about it, Please I need help

The markdown field is not (and was not in K2) core Kirby field. That means that you used a plugin in K2 and have to either replace the markdown field with a textarea or use the new K3 markdown field plugin:

I have a folder called fields inside site i.e /site/fields and a plugin called columns,

Plugins have to be registered in the /site/plugins folder.

yes the plugin is inside /site/plugins/columns, I still have the error ’ Invalid field type (“markdown”) ’

the plugin name is columns