Error (500 POST) on uploading video

Hi everyone,

I’ve created a file field in my blueprint to upload and manage images and videos. I can upload images but when I try to upload video i got an error message : ‘No files were uploaded’

In my terminal I got an [500]: POST /api/pages/works+projectname/fields/slideshow/upload .

I looked at my php.ini if it’s come from the “post_max_size” and “upload_max_filesize”, and it’s not coming from this.

I don’t know where it’s coming from.

Thanks

How big is the file you are trying to upload? Maybe you are running into a timeout. Are you testing this on a remote server or locally?

Hi my file is 9,7Mo heavy, look at my php.ini and I’ve seen it’s lighter than my post_max_size value. I’m working locally with PHP’s built-in server.

And what are you php.ini settings for

  • memory_limit
  • upload_max_filesize
  • post_max_size

`

memory_limit = 128M
upload_max_filesize = 20
post_max_size = 20M

Have you already tried to increase these values? Particularly memory_limit?

Where did you see this 500 error? Is there any more information in the logs?

And also, have you made sure you are looking at the correct php.ini?

max_execution_time is another value worth looking at…

I tried to increase all this values. And I checked, I modified the correct php.ini.

I got the 500 error in my terminal, in the logs of my php built-in sever. Just before the 500 error I got this PHP warning :

PHP Warning: POST Content-Length of 11881055 bytes exceeds the limit of 8388608 bytes in Unknown on line 0

Have you restarted the server after making those changes?

I changed the value, restart apache and when I look at my phpinfo page, the values are changed with the value I put in my php.ini.

Hm, I guess you have allowed other files than images in your file blueprint?

Although, if the file type was not allowed, you should get a dialog in the Panel…

Yes. I’m thinking, i’m running php 7.4 maybe by upgrading to php 8 can be an option.

I have tested that it works with no issues in my environment even with huge files with the built-in server runningPHP 8, but 7.4 should be no issue either.

I found the problem I was modifying php.ini in my /etc/php/7.4/apache2 folder but by running php built in server, the php.ini I needed to modify was in the /etc/php/7.4/cli folder…
I just have the idea to create a phpinfo file this morning in my project to check the path of my php.ini