Can't upload large files

I know this has been asked before on this forum, but none of the threats has provided me with a solution, unfortunately.

I can’t upload files larger than 5MB through the panel, although my php settings are set like this:

upload_max_filesize = 20M
post_max_size = 60M
memory_limit = 256M
max_allowed_packet = [no value]


max_input_time = 60
max_execution_time = 120

But according to this stackoverflow threat, those values shouldn’t affect.

I’m using my client’s French hosting provider Hosteur. And I just updated to the last Kirby (v2.3.2).

What else can I try? Could it really be max_allowed_packet? I tried changing it on the .htaccess, but it could be that the server doesn’t allow changes on php values through .htaccess, that I still have to ask…


Have you been able to sort this out with the hosting provider?

Not really, but it doesn’t seem to have anything to do with Kirby anyway.

You could test this with a little php upload script.

Maybe the PHP settings are useless if the provider simply does not allow bigger uploads (which would be ridiculous, but you never know). Are your changes reflected in PHP info?

Exactly, the provider doesn’t allow php values to be changed on .htaccess, and because of that, of course, my changes are not reflected on phpinfo.

I was testing upload times and file sizes thoroughly when suddenly a “The file could not be moved” warning starting to pop up every time, no matter how small the file was. I guess something similar to this. :sweat:

Hm, looks like it has to do with permissions, or maybe some sort of limit regarding max number of uploadable files or whatever. I’d contact the provider, most likely this is not a Kirby issue. Have you tested what happens if you try to upload files outside of Kirby with a simple HTML form and PHP upload script?

Yes, you’re right. I tried a simple php upload script and it fails the same way, with even a 100Kb file. The same script works fine on a different server (from a different provider). I will contact the provider now. I guess you can close this threat.