Kirby

(Cross-Origin) Request

Hi there,

I have a really strange issue … no matter which Plugin I install, I always get this error in my console in the Backend. It doesn’t happen when there are no plugins.

QuellĂĽbergreifende (Cross-Origin) Anfrage blockiert: Die Gleiche-Quelle-Regel verbietet das Lesen der externen Ressource auf http://localhost:3123/socket.io/?EIO=3&transport=polling&t=MeCK3ge. (Grund: CORS-Anschlag schlug fehl).[Weitere Informationen]

This is the same error message we saw in your other thread: Content in Panel (randomly) not saving; user logged out or cannot log out without refreshing

Is that in your local development environment or on the remote server?

Exact, I thought it’s one plugin where’s maybe broken. But seems to be happen at all plugins. It doesn’t matter if on localhost or on a server. There are also two other notices:

You are running Vue in development mode.
Make sure to turn on production mode when deploying for production.
See more tips at https://vuejs.org/guide/deployment.html

[HMR] Attempting websocket connection to http://localhost:3123

When you say it happens with any plugin, I guess you mean with any Panel plugin, not frontend plugins.

Do you just get the message or does anything stop working as a consequence?

Could you tell me which plugins you tested with?

Hi Sonja,

yes, Panel Plugins of course :slight_smile: tested with:

  • Color Picker Field
  • Markdown Editor
  • Sitemap from OMZ

Also tested with a fresh Installation from the Starterkit. Upload any Plugin, no matter which one and this happens

That’s again one of these things that I can’t reproduce at all.

Does this happen in any browser?

And again, does this result in any issues apart from the error message?

In all Browsers yes. It comes from this file which is created everytime I install a Plugin

[HMR] Attempting websocket connection to http://localhost:3123

media/plugins/.index.js

The described .index.js file has something to do with node_module … have you tested with the markdown editor? I have in mind that I have seen a line where this was noted

Yes, I installed the markdown editor. I wonder why you also get the “You are running Vue in dev mode” message.

Anything to do with webpack or something like this?

Not sure … the strange thing is that this happens on localhost and on the server.

Also tested on Strato and the same appears there … it has something to do with http://browserify.org/

Yep, sounds like it.