HTTP Error 500 after login to panel in remote install


I’ve been working on a Kirby site for weeks and everything was just fine, both in my local version as in my remote server one. Since last night, the remote Panel will show a 500 HTTP error after I login. Before that, the login form is displayed normally. On local, everything works normally.

I believe this started happening right after I manually uploaded a new content folder to remote. But when I put back the old content, it still didn’t come back to working.

PS: Since I’m not able to access the panel, I also can’t log out. Is there a shortcut URL to log out so that I can test the login form again (and that will hopefully work).

You can kill the session cookies in dev tools or close the browser window.

Maybe the rights of the manually uploaded folder are not set correctly?

Thanks, this works.

No luck with that.

I was wondering if it had to do with my GIT workflow so I reinitiated the whole repository from scratch and no: issue persists.

What is your Git workflow? Do you deploy the site with Git?

Have you tried to remove everything from the remote server and redeploy?

Yes, i’ve done that.

Found the source of the problem: I’m using the Field Engineer plugin and apparently it won’t work on remote. I guess a license is needed for live use, but… there’s no purchase button, @jenstornell!

Didn’t you say it the project worked before on that same server? Or did you add the plugin and then it stopped working? What about your PHP version?

I added the plugin in the last deploy, yes.

:open_mouth: You’re right! PHP 7.0 is needed. I’ll change that in my server config.

@jenstornell Have you stopped selling the plugin and if so, what does that mean for the license agreement. Why is the button temporarily disabled? Wouldn’t it make sense to add a little more information? Somehow a commercial plugin that you can’t buy seems a bit weird?

@daizumi @texnixe I could not make up my mind about it, so it was a mix with a commercial license without a purchase button.

I have not finally taken the step to let go, which mean I will not charge for it and no longer support it with fixes etc.

I’ve finally updated this page:

I still accept donations: :slight_smile:

@daizumi The license has nothing to do with your issue. It’s because there was not even a license code to add. I hope you figure it out. :slight_smile:

So I figured. :stuck_out_tongue:
Thanks for your reply!

1 Like