Login to Panel or Install (on remote) not possible

After reading through various topics/solutions here, I‘m afraid I have to open a thread again. I developed locally, uploaded all files to remote… and I cannot login to panel. What I‘ve done so far:

  • deleted all session files
  • tried on different browsers / emptied cache
  • created new user locally and uploaded it to remote but still get „invalid password“
  • deleted all user account files and made sure that panel.install is available but get an invalid CSRF token error

Any hints appreciated… Thanks!

What is the HTTP response from the server?

  1. code: 400
  2. details: []
  3. exception: “Kirby\Exception\InvalidArgumentException”
  4. file: “kirby/config/api/routes/system.php”
  5. key: “error.invalidArgument”
  6. line: 52
  7. message: “Invalid CSRF token”
  8. route: “system/install”
  9. status: “error”

Anything particular that I should be looking for? In the Response/Request Headers as well?

Yes, like here: Can not log in to panel - Invalid CSRF token

If you hint at the set-cookie there’s nothing showing up in the server response. But cookies are enabled though.

Have you made sure not to have the same issue as the guys in that thread with the wrong header being sent because of empty lines/characters in php files?

I’ll check all files tomorrow. Strange that on a local machine it works like a charm. Will give you a heads up if I find something out. Thanks!

Where are you hosting the site?

I‘m hosting at Hosteurope.de. Never had any issues with them over the past years. I can remember that I had tested a Kirby 2 site there as well.

Also, which Kirby version are you using? And which PHP version?

1 Like

Downloaded Kirby v3 2 days ago and my php version is 7.2.31

What might also worth testing is uploading a fresh starterkit to the remote, i.e. without any changes apart from setting the panel.install option in config so that you can install the Panel on the server.

I went over all files, no empty lines… except in the config.php itself! There the first line was empty… What a bummer :see_no_evil:
Thanks for your assistance, now I’m up and running!