“could not find driver” error when changing any content

Hello everyone

I am currently running an installation on a server and whenever I do any changes to the site‘s content I encounter a red box saying could not find driver. It is not the same error message as mentioned here. Here is a screenshot.

Any ideas on how to fix or debug this? The same Kirby setup is running perfectly on a different server… So must be some server related setting / issue, I guess.

Thanks for any ideas

Which Kirby version? Plugins? Custom code? Are these normal pages or virtual pages from a database? Anything else that might be worth mentioning?

Check if you console has more information.

Kirby v3.5.0
2 Languages
Plugins: kirby3-autoid and locator
Kirby runs in a subfolder called “content”

Console error is from the Kirby API:
Failed to load resource: the server responded with a status of 500 (Internal Server Error) /content/api/pages/test-page/title:1

The error from that API is

  "status": "error",
  "message": "could not find driver",
  "code": 500,
  "key": null,
  "details": []

As said before, the same setup runs on two other servers without any problems.

The path seems to be wrong, the content part should be there.

Try if it works if you set RewriteBase in .htaccess to this subfolder, or if you set the url config in your config.

.htaccess is/was already set. I changed the config setting URL, but this does not solve the problem, unfortunately.

(I also think the path is correct though, like I said I am running in the subfolder content)

I wonder if this path collides with Kirby’s content folder somehow.

No, unfortunately not. I just renamed it and tested it. But also as mentioned before, it works perfect on two other servers. I suspect some kind of server-setting but am not sure what exactly the error message means. I tried to disable/change caching driver settings in Kirby which did not help either.

What if you disable autoid plugin? Maybe sqlite driver missing needed for that plugin?

Ugh woah, thank that works. I will see if I can enable that driver