Can't setup panel because of httpd (apache) related issues

When trying to open the panel it shows 4 errors:

  1. /site/accounts is not writable
  2. The thumbs folder must be writable.
  3. The content folder and all contained files and folders must be writable.
  4. /assets/avatars is not writable

Im using a centos vps and the folder structure is /www/html/
So all kirby files are inside of html/

The httpd (apache, php5.4) service is started by the apache user, and is running without errors.
All files have the 664 permission and all folders have the 774 permission. The folders/files owner and group are set to apache:apache.

It’s still not working though, can anybody help?

When using
php -S localhost:8000
the panel is working without any errors, which means that the error is related to my httpd (apache) setup.

I still don’t know what’s actually wrong though

Have you already gone through the suggestions in other posts on this forum:

The Apache user and group seem to be correct on Centos. What a about ownerhip/permission of the parent folders?

I have a Centos VPS server, I would suggest using rSync to transfer the files, using the same user that the site belongs to for the ssh credentials (i use this bash script to deploy, and pull content down but dont do that unless your project is under source control because it will overwrite files without warning).

You can kick the bash script off with NPM scripts:

  "scripts": {
    "deploy:live:sim": "./deploy live",
    "deploy:live": "./deploy live go",
    "deploy:staging:sim": "./deploy staging",
    "deploy:staging": "./deploy staging go",
    "content:sync:sim": "./deploy sync",
    "content:sync": "./deploy sync go",

If you don’t know the username for the SSH connection, i’m guessing you also have cPanel/WHM. If you go into “list accounts” in WHM, it should tell you the correct user name. You may also have to enable SSH access for that user.

If the permissions/group on the /html folder are bad, it doesnt matter what persmissions the rest has becuase you need correct rights to the full path, not just below /html. i would check the user:group of the html folder.

If you havent used rSync before, there is a good guide here.


The problem is solved. There was an issue with SeLinux.
I have used this article to fix it: