Are blueprint tweaks too rough on the panel?

I admit I’m pretty rough on the panel. I create blueprints, input data, save, go back and add new fields in the blueprint, save, refresh the panel to see the new fields, go back to the blueprint add a few things, save…

This behavior has been leading to the following error message (which i cleaned up for better readability)…

Fatal error: Uncaught Error: Method name must be a string in C:\www\mywebsite\panel\app\src\panel\models\page\changes.php:71 Stack trace: #0 C:\www\mywebsite\panel\app\forms\pages\edit.php(23): Kirby\Panel\Models\Page\Changes->differ() #1 C:\www\mywebsite\kirby\toolkit\helpers.php(270): Kirby\Panel->{closure}(Object(Kirby\Panel\Models\Page)) #2 C:\www\mywebsite\panel\app\src\panel.php(306): call(Object(Closure), Array) #3 C:\www\mywebsite\panel\app\src\panel\models\page.php(133): Kirby\Panel->form(‘pages/edit’, Object(Kirby\Panel\Models\Page), Object(Closure)) #4 C:\www\mywebsite\panel\app\controllers\pages.php(68): Kirby\Panel\Models\Page->form(‘edit’, Object(Closure)) #5 C:\www\mywebsite\kirby\toolkit\helpers.php(270): PagesController->edit(‘contact’) #6 C:\www\mywebsite\panel\app\src\panel.php(428): call(Array, Array) #7 C:\www\mywebsite\panel\app\src\ in C:\www\mywebsite\panel\app\src\panel\models\page\changes.php on line 71

Any insight as to why this is happening?

To offer a bit more information… If i logout of the panel and log back in, then navigate to the page it loads (without the error), but If I attempt to save the page I do not get the fun save confirmation (happy face, top, right). After the failed save if i reload the page I get the same error message.

Do you get the error with multiple blueprints or just with one?

Just one blueprint.

I resorted to ditching the page and blue print then recreating it from scratch. That worked, but left me feeling defeated.

I closely reviewed the blueprint before ditching it, as well as the content text file to make sure there were no mismatches and/or syntax errors.

I suspect the drastic blueprint tweaks (e.g. field name changes, requirement option tweets, etc.) all while the panel page is open in the browser as well as theblueprint file open in sublime the system had a hard time syncing? Maybe some data is in some cache? Just not sure.

I imagine edits to the blueprints after the page has been created is common. No? Are there any actions regarding this workflow that need to avoided? What are common causes of such breakdowns?

Well, yes, making tweaks once in while is certainly nothing exceptional. Although I don’t usually have to keep making changes to my blueprints all the time. When I start out with the realization of a project in Kirby, I usually have a very clear picture of what sort of information needs to go where, so creation of the blueprints is pretty straightforward.

If you hadn’t thrown it away, I would have asked you to provide your blueprint code for testing. But it might indeed have been a caching problem after all. If you come across that problem again, could you please provide your code and the result in the content file so that we can look into this some more?

I’ll be sure to post the blueprint in question if/when it happens again. Thank you.

Does the provided error message point to any specific foul on my part?


I just had the same exact error. After combing my blueprint, I realized I’d forgotten a colon. This could possibly be your problem

Broken Blueprint
label: Text
type: textarea

Correct Blueprint
label: Text
type: textarea

Sorry for resurrecting a pretty old issue

I have the same problem right now.

  • Added a new field
  • Forgot colon
  • Went to that particular page in the panel
  • Added my info into the new field
  • Saved - nothing happened
  • Went back and forth to refresh
  • The error is persistent no matter what I try

Any more feedback on this would be greatly appreciated.

Have you logged out and in again and cleared the cache?

I did, however I tried a few times more and now it seems to be working as it should again. Many thanks.