404 file not found panel

Hi, I have just set up Kirby, it is totally awesome! I have a basic page up and running, but I cannot access panel, I get 404. What is wrong?

Hey, welcome to the Kirby forum.

Are other subpages accessible? If not, is the .htaccess file present?

What is your environment? Local dev or a remote server? Which PHP version? Apache or Nginx? …

Hi Thank you. I have access to templates/home.php. Htaccess file is present. My environment is currently local, but i uploaded to a server and had the same issue. I am using php OS X 7.2.25 and apache.

So the subpages of the Starterkit (are you using the Starterkit?) are not available either?

The the .htaccess file probably doesn’t have any effect. You can test this by adding some gibberish to that file, whereupon you should get a 500 error.

What exactly is your local development setup? Built-in PHP server? Something like Mamp/Xampp? Valet?

@pixelijn Yes you are right, when i typed in gibberish in htaccess it gave me a 500. I am using the plain kit. Correct i am using Xampp. Here is my htaccess:

# Kirby .htaccess
# revision 2020-06-15

# rewrite rules
<IfModule mod_rewrite.c>

# enable awesome urls. i.e.:
# http://yourdomain.com/about-us/team
RewriteEngine on

# make sure to set the RewriteBase correctly
# if you are running the site in a subfolder;
# otherwise links or the entire site will break.
# If your homepage is http://yourdomain.com/mysite,
# set the RewriteBase to:
# RewriteBase /mysite

# In some environments it's necessary to
# set the RewriteBase to:
# RewriteBase /

# block files and folders beginning with a dot, such as .git
# except for the .well-known folder, which is used for Let's Encrypt and security.txt
RewriteRule (^|/)\.(?!well-known\/) index.php [L]

# block all files in the content folder from being accessed directly
RewriteRule ^content/(.*) index.php [L]

# block all files in the site folder from being accessed directly
RewriteRule ^site/(.*) index.php [L]

# block direct access to Kirby and the Panel sources
RewriteRule ^kirby/(.*) index.php [L]

# make site links work
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php [L]


# pass the Authorization header to PHP
SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1

# compress text file responses
<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE text/javascript
AddOutputFilterByType DEFLATE application/json
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript
RewriteBase /jaque/kirby-blank/kirby/blank

That’s good, so we know it’s not a problem with .htaccess.

Could you please enable debugging in your config.php, maybe that gives us some more details.

Have you also checked that your Xampp settings meet our requirements and that all extensions are enabled?

in kirby/src/toolkit/Config.php I have added, i have not checked if xampp settings meet requirements, how do i do this?:


namespace Kirby\Toolkit;

 * This is the core class to handle
 * configuration values/constants.
 * @package   Kirby Toolkit
 * @author    Bastian Allgeier <bastian@getkirby.com>
 * @link      https://getkirby.com
 * @copyright Bastian Allgeier GmbH
 * @license   https://opensource.org/licenses/MIT
class Config extends Silo
     * @var array
    public static $data = [];

return [
    'debug'  => true

Please don’t modify anything in the core! the debug option has to go into /site/config/config.php.

@pixelijn sorry, yea this file wa blank, so i added: Is this correct?

	return [
	    'debug'  => true

Yes, but don’t add a closng php tag.

	return [
	    'debug'  => true

okay, this is done, what next and where do i see the debug?

Could you check what you get in your browser’s dev tools, in the console or in the network tab, please?

Stop, we removed support for PHP 7.2 in 3.5! You need at least 7.3. sorry for being slow…

Hi @JaquilineBrown, welcome and glad you enjoy Kirby (though obviously less right now as we all do when battling an issue :D).

@pixelijn is right, we dropped PHP 7.2 support with the release of Kirby 3.5.0. If the PHP version is something you can’t do anything about right now and want to battle that issue at another time, you could try the last previous version, Kirby 3.4.5: https://github.com/getkirby/kirby/releases/tag/3.4.5

Xampp should have an option to switch PHP versions though, although on a remote server, you have to check if the requirements are met.