404 Error on site


I’ve been using Kirby successfully on localhost to build and test my website over the last few weeks, but today when I uploaded it to my domain I could only access the home page - every other page gave me a 404 error

I’ve had a look around the kirby forums for similar issues and it seems like it has something to do with my .htaccess or config.php file, but I’m not 100% confident i know what I’m doing with this.

Currently in my .htaccess there is

RewriteEngine on

# Do not remove this line, otherwise mod_rewrite rules will stop working
RewriteBase /

and in config:

c::set('rewrite', false);
c::set('panel.rewrite', false);

Is this right? Can anyone offer some help to a rookie?

Thanks a lot
: )

You have URL rewriting turned off. Here is how those 2 files look by default:

click on the links to see the full files, do not copy paste from here



How did the URLs look when you had the site on localhost?

Oh ok cheers man. I didn’t have all of that in my .htaccess
Just to be sure, where should this .htaccess file be located?

On localhost the urls were simple - ie. www/projects/projectname

In your project folder;


Awesome, got it working now.
Thanks for your help, texnixe and ozy!