Which version of PHP to use on my Kirby 2.5.x. Site?

Hi,

I’m running my website on Kirby 2.5.7. and found out that PHP 7.2. has reached end of life.

Which version of PHP can/should I use on my site?

Additional question: I’m planning to (eventually) upgrade to Kirby 3.x, but in the meanwhile, I should probably update Kirby to 2.5.13 - is there anything I should be aware of when doing this?

Is not the latest version which is 2.5.14 (there was a security release recently)

Kirby 2.5.14 is compatible with PHP 7.4

Many thanks for your swift answer - time to update! :slightly_smiling_face: