Translating URLs

Hi, I can’t set the german language on URL , I have version 4.
can you help me?

Version 4 of what, please?

I have zero-one-4.4.0 installed,
and Kirby version is 3.7.3

Ah, ok, see the docs: Translating URLs | Kirby CMS

I have changed the url into German but again it shows error. See attached picture.

URL appendix doesn’t change the language.

I thought you had a multi-language site. That doesn’t seem to be the case.

If you click on “create from title” and you set the slugs to de in your config file, it should create the correct url appendix.

I already tried it, but it doesn’t work


Hm, I can’t even tell from what I see if you have a multi-language site or not.

@mrfreedom Could you please help to sort this out, don’t have access to your theme.

1 Like

which part do you want to show?


let’s start with the config settings first.
This is what you’d put into the config to enable multiple languages:

return [
    'languages' => true

Then you’d need to either go into the panel and setup the languages you would want to have. Alternatively you create the languages files manually, eg. for German it’d be: /site/languages/de.php

Next, if you want to convert German special characters in the slug into a slug that can be safely read by search engines, use the slug-setting for that language, for German it’d be:

return [
    'languages' => true, 
    'slug' => 'de'

This will then convert every special character into its ascii-equivalent, e.g. übel → uebel. Once it’s correctly enabled you can type in any character and see it converted afterwards. I believe, your config has a bug somewhere, otherwise the above shown wouldn’t happen.

Note: You should not use characters like ä and the like in an url anyway. While you technically can it also raises a lot of other issues you don’t want to dive into

To add to what @tojai wrote above:

The config keys is called slugs not slug: slugs | Kirby CMS

But it doesn’t make sense to set this to German in a multi-language environment, where it is picked up automatically per language.

So the big questions is: Do you have languages enabled in your setup (check if there are any languages defined in the Languages View in the Panel or if you have any xx.php files in the site/languages folder.

1 Like

As far as I know, those special symbols you want to see in the URL are not allowed symbols
What is URL Encoding and How does it work? | URLEncoder).

These letters: Ä, Ö, Ü and ẞ are not allowed in URL.

Haha, maybe should have watched the video, I thought the slugs were wrong while they are perfectly ok…

1 Like