Toggle always shown as "true" in table layout even when set to "false"

I have a toggle “hideOnHomepage” in a page blueprint. It is set to “false” by default and there are some pages that have it set to “true”.

In the blueprint of the parent page i want wo display all the containing pages in a table view. In this table view all the toggles are set to “true” which is not correct.

  label: Auf Startseite ausblenden
  type: toggle
  default: false
    - Nein
    - Ja
  headline: Veröffentlichte Seiten
  type: pages
  layout: table
      width: 1/8
      width: 1/8
      width: 1/4
      width: 1/8
  status: published
  sortBy: title asc
  limit: 50000

Hi @degl and welcome to the forum. I tried to reproduce your issue in a Starterkit but could not. My toggle shows true or false using Kirby 4.1.2:

Empty ones are where the field is empty, because I added it just for testing.

Which Kirby version do you have?

I am using Kirby 4.1.2 as well.

For me it looks like this:


When i set “type” to “text” then it looks like your example and the values are shown correctly.

  label: Auf Startseite ausgeblendet
  type: text

Nonetheless i prefer the view with the toggles which i can set from the parent blueprint because that would be an easy way to manage this setting for all the subpages but of course i want to see the correct values.

Hm, ok, in your case it actually shows as toggle, while my example shows a text value.

If I explicitly set the column type to toggle, I get the same result with all toggles set to true.

But the toggle view seems to be the default one, wondering why it doesn’t show up in my first test.

That seems to be a bug, then.

Ok, thank you for figuring that out.

So for now, my solution is to set it to text and maybe the toggle view will work with the next update :slight_smile: