Timezone error in panel

There is a wired error, which I don’t understand:
date(): We selected 'Europe/Berlin' for 'CET/1,0/no DST' instead

It appears in the panel when I want to click on an image for the file settings, as well as I want to erase the file. There are no time settings in the blueprint, or what so ever.

Any idea what I can do to solve this?
Kirby version: 3.3.5
These solutions didn’t work for me:

  1. SetEnv TZ Europe/Berlin – in .htaccess
  2. date.timezone= “Europe/Berlin” ; – in php.ini
  3. date_default_timezone_set(‘Europe/Berlin’); – in index.php

Does this happen locally or remote? Which PHP version? Does this also happen with a fresh, up-to-date kirby version?

It happens only remote. Locally it works as expected.
On another websites it works. –Kirby
I still have to investigate the PHP version.

I will try to update.

PHP Version 7.4.25

Does this error actually pop up or is it only in the console? To me that sounds like some sort of server misconfiguration rather than anything Kirby related.

I worked in the wrong directory. 1&1 changed something there – so the update was not working.

The errors were popups. ^^

I take it back. not solved…
Bildschirmfoto 2021-12-06 um 17.40.36

so now I can erase the images but i can’t save the changes in the file data.
Kirby version is now: 3.6.0

Do you have multiple PHP ini files? Some hosts do this, and if your using cPanel and set certain things, it will create a PHP ini in your webroot which may conflict with or override the timezone settings.

Thanks for contributing!

no. only one php.ini

that is what it says:

error_reporting = E_ALL | E_STRICT;
log_errors = On;
display_errors = On;
error_log = /dominik_antoni/php-errors.log;
date.timezone= “Europe/Berlin” ;

When you output phpinfo(), what is the output in the date section?

Ah, have a look here:

Looks like you are using wrong types of quotes around “Europe/Berlin”

The quotes shouldn’t appear in the phpinfo table.

Actually, quotes are not necessary at all here,

date.timezone = Europe/Berlin

would be correct.

1 Like

Now it works!

But strange anyhow. There must have been a change in PHP, the hoster or kirby because before it worked perfectly and all of a sudden it didn’t.

Thanks for your great support.