The section type "pagetable" is not valid

Hello,

As the title said, until I have transfered my website from one host to another, I have the following message concerning the pagetable field

The section type “pagetable” is not valid

I tried to remove and re-install the plugin manually, nothing. And I tried to enter a bad field type to see what the panel proposed to me and it propose pagetable in the list:

54

I don’t know where it could come from, @sylvainjule do you have a track ?

Maybe we can help if you share your blueprint file

And what Kirby version are you using?

My blueprint file doesn’t change from before to after the transfer:

Here is the site.yml

title: Site
unlisted: true

tabs:

  pages:
    label: Pages
    icon: text
    columns:
      - width: 2/3
        sections:
          sectionsList:
            extends: sections/listed
            status: listed
            headline: Pages list
      - width: 1/3
        sections:
          unlisted:
            type: pages
            status: unlisted
            headline: Unlisted pages
          drafts:
            type: pages
            status: draft
            headline: Drafts

Here is the sections/listed.yml

type: pagetable
image:
  cover: '{{ page.cover }}'
limitOptions:
  - 10
columns:
  title:
    label: Page title
    text: '{{ page.title }}'
    type: text
    class: my-title-class
    sortable: true
    searchable: true
    width: 1/2
  date:
    label: Date
    type: date
    text: '{{ page.modified("Y-m-d") }}'
    dateInputFormat: 'YYYY-MM-DD'
    dateOutputFormat: 'MMM Do YYYY'
    width: 1/6
  category:
    label: Category
    text: '{{ page.category }}'
    width: 1/6
  state:
    label: State
    text: '{{ page.status }}'
    width: 1/6

@texnixe I am on 3.2.4 version

I just tested on 3.2.5 and I don’t get this error message (however, it doesn’t display any pages and I’m not sure why that happens).

Edit: With 3.2.4, your blueprint example works fine for me in a Starterkit.

@sylvainjule Is this a bug in 3.2.5 that no pages are shown? I get No pages yetwhile it works alright with Kirby 3.2.4.

Have you deleted your media folder?

Huh, there is indeed a bug in 3.2.5, the Pages section must have been refactored somehow (? @byybora you might have followed this more closely than me?) . I’ll look into this.

Should work on 3.2.4 though.

I opened the issue after 3.2.5 released

1 Like

Could it conflict with extends type (group etc…)? May be you should use like that?

sections:
  sectionsList:
    type: pagetable <<<<<<<<< Add type here
    extends: sections/listed
    status: listed
    headline: Pages list

And remove type property from sections/listed.yml

I just tried, and nothing changes.
I tried to write it without extends too and nothing.

I have tested on 3.2.4 and working.

@byybora I just update to 3.2.5 to try, nothing, then I downgrade to 3.2.4 and always nothing.

I think there are two possibilities:

  1. There is a problem with the blueprint file (Two errors appear on the screenshot in the first post)
  2. If any, it is due to other plugins

Did you try on fresh 3.2.4 install?

@Fromager Is the code in your site.yml all there is in that file?

There seems to be nothing wrong with the blueprints, I tested them in a 3.2.4 Starterkit without any errors.

Does the blueprint work if you change the section type in listed.yml to pages? Or do you then get the same error?

@byybora yeah two errors appear on the on the screenshot in the first post, as I explained it, I did to test if the panel suggest me to put the type “pagetable”, what it did.

@texnixe no, the code in the site.yml is all there is in that file, one pagetable and two pages.

Well, as @byybora said, it could be due to other plugins. So I’ve don’t replaced all plugins as I did before, but removed all and put them one by one, beginning by pagetable… And everything is running good.

Thank you two for your help !

Did you find out which plugin caused the issue?

No, I just put them one by one, with the same folders used before the online transfer (to be sure to find it) and nothing appears wrong that time… Really strange.

@texnixe maybe it was the missing ! problem with js code of plugins? i searched but could not find the issue or forum thread where we discussed that (since on mobile phone).

@bnomei You mean this one: https://github.com/getkirby/kirby/issues/1931?

That was supposed to be fixed in 3.2.4 though?

1 Like