Subdomain and templates

I’m having a weird issue on a kirby site installed in a subdomain (sub.mysite.com)

I’ve several different .yml blueprints, but only two of them are available to choose from:

image

I don’t have idea why those 2 are ok and the other ones are not!

Beside that, a few pages that I created locally with the right template (“Autore” template) are shown on the pre-production site as if they were created from “Page” template.

Don’t know if the issue is somehow related to the fact the site is installed in a subdomain… Any hint? Thank you

subdomains should not make a difference. Can you please tell us what your server is running (PHP version, Nginx, Apache), and the hosting provider?

have you checked permissions on the files and folders? the indentation is ok in the blueprints?

Are you using capital letters anywhere in file names? Have you made sure that there are no stray additional text files in folders?

Have you restricted page creation to certain templates anywhere?

@texnixe

  • yes, I named the blueprints files with capital letters
  • yes, I restricted page creation to certain templates.

Now I will rename the files… thank you… but - why you can’t use capital letters?

You could, but then you would have to name your text files accordingly. Unix-like OS are case sensitive. Therefore, file names should always be lowercase.

1 Like

Are u running Centos on live server but ubuntu locally? Double check the casing, i would go lowercase. i had this issue when Ubuntu was used locally, but Centos broke. (filenames were lower case but in the code, I hadcapitalised or camel cased it somewhere). Ubuntu didnt blink, but Centos did :slight_smile:

Actually no. Server is Apache, while locally I’m running Windows 10 with Xampp.

Yes, on Windows it doesn’t matter because it’s not case sensitive. As I said above, to ensure interoperability, always use lowercase.

Sure, but what operating system is it running on?

Probably is related as well: locally (win10) I can write in the text field of a page caffè, and the page shows caffè correctly. On the server it shows “caffè” …why? :disappointed_relieved:

Don’t know how to check…

How did you transfer the files? That looks like a mangled UTF. Windows uses different line endings / encodings to unix.

What character set are you using? Does this happen only with text that you output using the html() method or also with kirbytext()?

Make sure that your files are saved as UTF-8 without BOM. Do you use the Panel for saving content or do you edit the text files manually?

Pop a phpinfo.php page up on your server. instructions here. remember to delete it when your done, it can be a security risk as it gives information away.

@hvsrmusic What code editor are you using? Most editors like Atom, Sublime, VS code usually say the current files encoding type somewhere along the bottom edge of its window. Usually if you click it, it will give you some options to change it. Heres mine in Atom:

You might also want to check your Apache character encoding. Try to uncomment this line in your .htaccess:

#AddDefaultCharset UTF-8

Yes, I’ve added

AddDefaultCharset UTF-8

to my .htaccess and now it works. Thanx you so myuch @texnixe and @jimbobrjames.