Strange new Error Message when editing subpages


Most certainly, i did something wrong. Newly i get this message when i want to edit subpages:

Warning: file_exists() expects parameter 1 to be a valid path, string given in myserver/kirby/toolkit/vendors/yaml/yaml.php on line 542

I already replaced the Kirby and the Panel folder. The Problem stayed the same. What information do you need from me to be able to determine where the problem may come from?

many thanks

Have you tried to replace the toolkit folder with a new one as well?

Have you updated Kirby recently?

Yes, i copied the whole kirby and panel folder, so the toolkit folder is replaced to. And no, its the same version that i started with. 2.3.2

may this be the problem?

[Mon Sep 12 14:40:51.706233 2016] [:error] [pid 94172:tid 34645060608] [client my-ip] FastCGI: server “/var/run/hcgi/45703” stderr: PHP Warning: include_once() [function.include.php]: Failed opening ‘/myserver/kirby/toolkit/bootstrap.php’ for inclusion (include_path=’.:/usr/local/share/pear’) in /home/floriana/www/ on line 7

Failed opening…bad server!

I have seen this issue before. The reason was that a file name contained a null-byte (ASCII 0). Please try renaming all of your blueprints. You will probably not see a null-byte there, but writing the file names again should fix it.

That was probably when you re-uploaded the site and the Toolkit was still missing. According to your error message from the first post, the Toolkit is loaded, so this can’t be it.

blueprints as in /site/blueprints ?

thank you i rename them all now

Yes, exactly, the files in /site/blueprints.

Thanks, it worked.

The Problems seems to be a Software that i use to mount my webserver’s directories to my mac os. I use mountain duck. It may be that this adds somewhat a null-byte to the name. When i reuploaded all blueprints via FTP, it worked.

Thank you all for your perfect support!! :grinning:

1 Like