[SOLEVED!]Subpages broken on mamp


#1

I’m I have installed Kirby and the Patara theme on a local dev. Mamp on my mac.

Only thing. The subpages on the blog part is not showing.

I have followed all the suggestions from the troubleshooting page

But nothing seem to help?

Be gentle I’m new to Kirby :wink:


#2

Do you get an error?

Only subpages of /blog aren’t working? Or no subpages at all are working?


#3

No I don’t get an error and I have just tested and no subpages are shown… :frowning:


#4

What exactly is the problem? There are no. pages on. the blog page or if you click on a link to a. subpage. you. get the error page?


#5

There are no pages shown.
How it looks on the theme developer demo page:


#6

How it looks on my local setup

My first impulse was to look at rewrite issues. I have just upgraded to Mamp pro 5 and got a little lost in serverside settings. Should I keep on this path to see if it’s the issue?

thanks a lot guys


#7

What I could imagine is that the code filters by visible pages and your blog subpages are not visible, i.e. no date or other number prepended?


#8

Hmm… all have dates, but how do you prepend number? Seems like the theme demo pages has a number, but my test page doesn’t?
CloudApp


#9

In Kirby, pages have two states, visible and invisible. There should be toggle in the sidebar of each subpage where you can change the status from invisible to visible.

Or. you can click. on “Sider” (Pages), which will. bring you to. the pages view, where you can drag pages from one state to another. After you have done that, your subpages should appear on. the blog page.


#10

Thanks … gotya. But all seems to be set to visible…

CloudApp


#11

Hm, that is weird, could you post the /site/templates/blog.php template? Or upload the project somewhere as a zip file for testing?


#12

The whole project here… https://www.dropbox.com/s/beob8oxntz8emwc/vivelill.zip?dl=0

and blog.php https://www.pastiebin.com/5b6c52becbe02


#13

The theme has the multi-language feature enabled, therefore all content text files need a language extension. If you change blog.txt to blog.en.txt, everything will work as expected.


#14

Crazy awesome! I could have lived a whole life never gotten to that solution👍