Smartypants configuration options in kirby 2.4.1

Since Kirby 2.4.1 my smartypants setup in config file is not working. How can I overwrite ‘smartypants.doublequote’?

Can you show your current config?
Is it placed in site/config/config.php or somewhere else?

There are two separate options:

  • smartypants.doublequote.close

Are you using those?

c::set(‘’, ‘„’);
c::set(‘smartypants.doublequote.close’, ‘“’);

I was always using this, worked in Kirby 2.3.2 but no longer in 2.4.1

There’s already an issue on GitHub:

1 Like

Would this work as a workaround?

// site/config/config.php

$kirby = kirby();
// Workaround for
// Start the SmartyPants component, without using it, to import its default options
// Then set the desired options for SmartyPants
$kirby->set('option', '', '„');
$kirby->set('option', 'smartypants.doublequote.close', '“');

I haven’t tried it and am only 60% sure that it would work. :smiley:

This should now be fixed on the dev branch.