RewriteBase on internal Debian Server

Hey Guys,

I´m stuck with Kirby right now, I badly have no Idea how to get this working.
I downloaded a fresh copy of Kirby, moved this to de Debain Server (in my local Windows Network) and wanted to run Kirby there, which worked pretty nice, but there is some fuck up with RewriteBase i think, cause only the home page is working, the others not, e.g. if i´m clicking on a link.

\DEBIAN64\www\site\ is where my Kirby files are stored. I can load the Site in my Network on \brwww\site\ for now, but to get it work i have to get the links on my site working…^^

(It´s an Site only for internal purposes, so it should always be on “Debian64” …

Hopefully someone can help me :smile:
(Yes I´m looking at you @lukasbestle)


It depends on how your subpages “don’t work”. :smiley:

If the server has been setup recently, the reason might be that rewriting is not enabled. This is the case if the subpages throw HTTP 404. If they throw HTTP 500, this is not the problem.

So if you get HTTP 404, try enabling mod_rewrite by using a2enmod rewrite on the server. Sometimes you also need to change the configuration file /etc/apache2/sites-enabled/000-default and set AllowOverride to All.

Basically that’s why I told you to use SSH yesterday. :wink: