Panel Reformated all of my posts date prefixes

Good afternoon,

The Panel reformatted all of my post files date prefix.
What was previously expressed using a Unix epoch date format was reformatted to YYYYMMDD-POSTNAME/

Is there anyway to prevent this from happening.
I don’t remember it being a problem in previous versions of the Panel.
I just upgrade to version 2.65


Have you defined the format in your blueprint? The default numbering scheme for date based formatting is Ymd, but you can change that.

Thank you texnixe,

I was unfamiliar with using ‘LL’ as a date format.
I am wondering if I leave the date function out of the blueprint will the Panel still try to convert the format of my posts?

Thomas brand

Thanks again, I got to the bottom of it.

The num: date tag in the default blog blueprint was reordering my posts and pages.
Removing it let me keep my original format.

Thanks again,

How do you add the date to your posts if not through the Panel? I’d set the format to U in the parent blueprint, so you get the right format when you add new posts:

    mode: date
    field: date
    format: U

I don’t use the Panel for post creation. Only a quick edit. Everything I write I write in VIM.

Where is the num format U value documented?

Thanks again,

I see. Be careful then with using the Panel all of a sudden if your blueprint settings are not correct. That might mess it all up.

The U format is not documented in the Kirby docs but in the PHP documentation I linked to (and which is referenced in the Kirby docs). You can use any valid PHP date format.