Panel page is not accessible with the error: "Cannot use "parent" when current class scope has no parent"

Hi. Maybe you can give me some pointers on how to solve this issue…

An old site I developed recently started to give me this error when accessing some pages on the panel

“Cannot use “parent” when current class scope has no parent” error.

I’ve tried to run the site locally, and I don’t have the issue.

I have Kirby version: 3.1.1
And both locally and on the server I have PHP version: 7.4

Any hint?
Many thanks!

Hm, support for PHP 7.4 was added with Kirby 3.3.2. I would assume that this causes the error, even though it’s a bit weird that it doesn’t happened locally. But same error was reported here: Local websites error - #11 by Fleix and was also due to premature update to PHP 7.4.

For Kirby PHP support matrix, see

Thanks! Ok, I’ll try updating Kirby then.

I’ve downloaded Kirby 3.3.2 from GitHub and replaced the old kirby folder in my local server folder. But when I do so, the website and the panel don’t render at all (empty body).

To check if there was any mistake in how I upgraded Kirby, I’ve tried with downloading Kirby 3.1.1 also from GitHub and replacing in in my local server folder and that works.

Any hints on what I could do?
Many thanks!

You always have to clear the media folder when you update to a new version, also make sure the cache is cleared both in the cache folder and in the browser.

I cannot check this now, but major upgrades (from 3.1 to 3.2 etc.) might also have breaking changes and might also require updates of plugins and/or your code.