Panel not working correctly


Unfortunately the panel doesn’t seem to be working correctly on my site. I managed to login but there are a number of blank screens when I try to action certain things. For example: logging out, site options, account edit.

I also tried downloading the site to work on it locally and the panel appears as a blank page. All pages are working correctly on the site. Any other information I can get please let me know.


What Kirby version are you using? Please always choose the right category :slightly_smiling_face:

What is your local development environment? Which server? Apache? Nginx? Other?

Have you enabled debugging in your config.php? Are there any error messages in your browser console?

Thanks for the quick reply. And apologies for the incorrect category.

Version 2.5.12
Local development using MAMP with the Apache server.
I enabled the debugging in config.php and saw no errors in the console.

Mamp usually works with Kirby 2 out of the box, without any additional requirements (at least, if you are running an up-to-date version of Mamp). Have you made sure to clear your browser cache, remove any sessions in your browser and then log in again?

Yup I’ve tried all those things. I think there’s something wrong.

As I mentioned the site is also online. The panel appears as a blank page online now and redirects to /panel/login

Have you tried to remove the kirby and panel folders and replace them with freshly downloaded ones?

Is there not an issue with the versions? The site I have has separate Kirby and Panel folders whilst the starterkit I downloaded doesnt.

Hope I’m right in saying that.

You told me you are on version 2.5.12. That version is the old Kirby version and has two folders, one for Kirby and a second for the Panel-

Then there is Kirby 3, with only a kirby folder (and a panel folder inside it).

So we first should make sure we are talking about the right version and you have to download the right one, for kirby 2 from here:

Yea I’m talking about version 2.5.12. I didn’t realise you could download version 2.

I replaced the folders with the new ones and still have the same issue.


Is the mb_string extension. enabled? What is your PHP version?
Have you checked if there are any errors in your blueprints?

I replaced the htaccess file with the new one I downloaded and it seems to be working now. Thanks for all your help though.