Panel not found after switching to new php Version

I have swapped the kirby and the panel folder with the newes Update. This is enough to Update or do I have to set some settings?

I’m working in a local Docker Container with ddev.

PHP is set to 7.2 according to the phpinfo

I tried with a fresh Starterkit and couldn’t access the panel on there neither. Does this mean that anything is wrong with my local Setup? Other Sites I have installed locally run fine.

Yes, swapping the /kirby and /panel folders is enough, no other settings required.

With a fresh Starterkit, what is the error you get when trying to access the Panel?


The page has not been found.

The same error, just in the Starterkit Design.

Hm, I have no idea.

If mod_rewrite is enabled and all subpages work and the .htaccess file is present and not ignored, and the mb_string extension, then everything should actually work.

Have you only tested the 2.5.13 Starterkit in your Docker container or also on the live server?

Everything you just mentioned I checked.
I will have a chat with a Coworker of mine tomorrow. Maybe he can help me.

I only changed the PHP Version of the Live Server once, to check if it works. I didn’t change anything there after. The Site is still running with php5.6 and I want to keep it up.

So if I cant figure it out, I will try to setup a Stage Server and see if I can get it to work. If not I’ll update this ticket tomorrow.

Thank you for the needed help!

Today I copied the Live Site to a Stage Site and updated to 2.5.13. Finally I could access my Panel.

I found that there is a bug with Docker that for some odd reason it didn’t upgrade to 7.2 and instead mashed up different php versions. I was accually impressed that the Site still worked and only the Panel wasn’t found.

I now tested in a different Docker container and it worked there.

In the end your very first suggestion, to update to 2.5.13, worked.