No thumbnail generated

Hi everybody,

I’m running a Kirby on an Apache server. Everything is going fine except for the thumbnails that aren’t generated… In the media folder there are only .JSON files, but no images.
I’ve already tried to trash the media folder and check the permission.

Any Ideas ?


What is your development environment?


The server is running Ubuntu with Webmin (1.941), Apache2 and PHP 7.3


Does your setup meet Kirby’s requirements? In particular, is the GD library installed and enabled?

Does everything else (subpages, the Panel) work?

Yes, everything else works perfectly.
I’ve tried the GD and ImageMagic setup… but no change…

The pictures are renamed in the img tag (e.g. scr="") but not modified…

By the way, thumbnails are perfectly generated on my local setup (MacOs + MAMP).

Hm, since the jobs are created, it can’t really be a permission’s problem.

Are you creating lots of thumbs at once maybe? What if you don’t create thumbs but use the standard image URL, do these files get copied to the media folder?

What about the size of these images?

the thumbs are generated first time they are requested.

  • what are your apache servers cache expiration settings for files with image mime types?
  • what is the html code and other error returned for the image request (browser dev console).

Thanks for your answers

@texnixe : I’ve tried with only one thumb on a page : same issue even with 100px file.
Standard images are correctly copied in the media folder.

@bnomei : where can I find the cache expiration settings ?
no error message in the console…

I’ve even tried with the example code :

if($image = $page->image()):
    echo $image->thumb([
      'width'   => 300,
      'height'  => 200,
      'quality' => 80

Do you have any expiry settings in your .htaccess or server configuration file?

None, it’s the default .htaccess file, from the plainkit repo.

Did you make sure that you did not simply enable GD or ImageMagick in Kirby, but also in your PHP config?

Doing a phpinfo(); on a secret page is helpful, you should see GD Enabled somewhere.

I would suggest having a look at your Apache access and error logs, too, as they likely will tell you what is being requested exactly and what could cause the failure.

have you tried deleting the media/pages/ folder on production server?

Thanks for your answer.
You are maybe right ! I was pretty sure GD was activated, but the phpinfo(); says the opposite ! I’ve ask the IT guy to install it because I’ve no root access on the server.

I let you know if it works.

Thanks again.

Yes, many times, unfortunately with no luck.

The IT guy finally installed GD and everything works fine now.

Thank you for your help.


1 Like