Leave time field empty by default

I have a non-required time field in my blue print. When I create a new page / edit an existing page, the field gets filled with the current time. Is there any way to leave the field empty by default? A simple


didn’t work.

Looks like a bug to me …

Okay, with a somewhat hacky

default: 24:00

the time field stays empty for new subpages. But as soon as I save, the time field gets filled with the current time, again :smiley: Should I create an issue?

Seems to be a bug that sneaked in when fixing the default: now option for the time field. This pull request should fix it: https://github.com/getkirby/panel/pull/475

1 Like

Great, thanks, that was quick. :smile:

1 Like

Until it gets to the documentation, I’ll mention it here as well:

There is also an override option for the time field. override: true will pre-select the default value every time from the time select menu when editing a page in the panel, no matter if a value has already been saved or not.