Kirby CLI can't install or update

Whenever I try to use the kirby CLI I get the next error -

Downloading from:

Warning: file_put_contents(/tmp/ failed to open stream: No such file or direc
tory in C:\Users\lcd34\AppData\Roaming\Composer\vendor\getkirby\cli\src\Command.php on line 66

it happens with any file that it downloads (plugins kirby update kirby install)

Anyone knows how to remedy this? Thanks!

The CLI wants to write to disk but it seems it can’t create the /tmp folder.

This is weird as I didn’t change anything in my settings except for updating it. It worked before.
Also no other composer commands that need to write have problems, do you have any suggestions on what to do?

Have you tried to reinstall the CLI?

Yes, couple of times.

I have invited Lukas and Bastian to the discussion, afraid, I can’t help with this.

This issue seems to be related to Windows, as the path /tmp is wrong there. Have you tried installing the old version of the CLI again? That’s important to verify that it’s indeed the update that caused the issue and not some change in the setup you don’t see.

This makes sense - where do I get an old version of the CLI? github has only master and dev repos

You can choose a version from the tags list (tag tab in branches)

We live and learn! will try and update you.

1 Like

The old version does indeed work. I’ll stick to this for now.


Which old version and which new version did you use? We can then try to find out what changed between those versions.

I used version 1.4,
The one before last if I’m not wrong.

Yes, that’s right. Seems like version 1.5 was never tagged/released, it was an intermediary version.

Thanks, I have opened an issue on GitHub.