I don't see my blogposts via the panel

After upgrading from Kirby 2 all my old blogposts don’t show up via the panel. Also some of my pages are not back. The ones that rely on default.yml.

Maybe you have filtered your section to exclude the default.yml?

I have to check this. But what about all the blogposts?

I don’t know your setup. Have you set up a pages section in your blog.yml for the posts? You always need pages sections for pages and files sections for images now. Have a look at the example blueprints and the Starterkit to get an idea how it all works now.

Yes, I changed my setup to the ones in the example.
I can add new posts but now old posts show up.

What is the template you use for your blog posts? articles like in the example? Have you made sure to define the correct template in the section?

For my blog I have used four blueprints:
article.foto.yml, article.zeichnung.yml, article.text.yml and article.link.yml.

How can I implement this in my sections > articles.yml?

There I have
template: article
but need the four variants above.

Thank you!

  - article.foto
  - article.zeichnung
  - article.text
  - article.link

I had tried that before and get the following error for the panel:

The JSON response from the API could not be parsed. Please check your API connection.

Hm, I’ve seen that error only once and the reason in that case was a server issue: https://getkirby.com/docs/guide/troubleshooting/panel#panel-error-messages

Might be different in your case, but the template settings work for me.

My provider says: “die HTTP Methode Patch wird von uns nicht blockiert, es gibt aber auch kein Apachemodul selbst, was damit umgehen kann.”

The panel works if I use
- article.foto
- article.zeichnung
- article.text

But there are still no old articles. I only get them to show up if I change the name of article.text.txt to article.txt.

Hm, but if you can create new articles with those templates, then that seems to work alright. Seems to be a problem with those old articles, whatever that is. Could you send me a zip of your project or parts of it with those articles in it?

No I can only create new blogposts with Pages/article. Maybe there is the error?

That’s really weird, I tested with templates with dots without problem.

When I use

  • articletext
  • articlelink

    instead, I am presented with a choice. I can then create new articles. But obviously the old ones don’t show up.

Did you use the same hosting provider/environment when using Kirby 2 with these blueprint filenames?

It is the same server but a different folder.

I will have to change everything to work without dots now.

Hm, unfortunately, I have no idea why the dots would work with K2 but not K3 in the same environment.

Are you using any plugins??
Have you tried with a fresh Starterkit?

No to plugins and no to a fresh Starterkit too. This has taken way too much time for an update. It works fine now without the dots.

Thank you for your quick responses. I appreciate it a lot!

I had a similar problem: blog posts were not displayed in the panel and an error message appeared: „The JSON response from the API could not be parsed. Please check your API connection.“ The problem only occurred on the web server (provider: 1&1 Ionos), not on my local server.

I was able to solve the problem by changing the date format in page blueprint. Before it was:

  info: "{{ page.date.toDate('%d. %B %Y') }}"

I changed it to:

  info: "{{ page.date.toDate('d.m.Y') }}"

Date handler in config.php was and is set to:
‘date.handler’ => ‘strftime’

1 Like