How to enable table block?

I’m learning Kirby by playing with the Starterkit. I see that the Table block is not available on the About panel page, presumably because kirby/kirby/config/blocks/table/ does not contain a table.php. All the other default block types have a respective .php file, so I gather that’s what triggers their availability to the block selector.

Using the sample code on table | Kirby CMS, I’ve added:

  • kirby/site/blueprints/blocks/table.yml
  • kirby/site/snippets/blocks/table.php

I expected to see the Table option appear in the blocks selector on the About page Panel, but it doesn’t. What am I missing…?

I guess you have to add it to the fieldsets manually: Blocks | Kirby CMS

Circling back to this, for any other noobs who might end up here…

@texnixe got me on the right track. I found that the default fieldset available to Layout, when none is specified, simply doesn’t include the table field—probably because a table needs those other files set up. To override the default fieldset you have to specify all fields you want available. Including ‘table’ in this fieldset (in about.yml, in my case) makes the table option appear when adding a block in Layout. It uses the kirby/site/blueprints/blocks/table.yml and
kirby/site/snippets/blocks/table.php that I had set up, per table | Kirby CMS.

Excerpt from about.yml:

        label: Layout
        type: layout
          - "1/1"
          - "1/2, 1/2"
          - "1/3, 2/3"
          - "1/3, 1/3, 1/3"
          - heading
          - text
          - list
          - table
          - image
          - gallery
          - video
          - code
          - markdown