Help! Empty page for one language :( Rest works fine

I’m working on this website and everything was fine. But now disaster stroke: On I only get to see an empty default tempate. The german content file is not found. If you switch to English everything works perfectly fine.

I tried everything:

  • Reuploading the file
  • Changing the file permissons back and forth
  • Renaming the content file and the template

Nothing works. The site is on 2.0.6.

Any help would be greatly appreciated!

Did you try switching on debugging in your config:

c::set('debug', true);

Yup… no output. And the server logs are empty too.

did you check the content files on the server? anything weird there?

No, everything looks perfectly normal. I’m going to redeploy the whole website and see what happens…

I can’t find my problem… Apparently it exists since a while as even a redeploy didn’t fix it. The same problem occours in the panel: An empty default blueprint is loaded. When I make any changes (e.g. to the title) and save, the changes are not persisted. Any ideas?

EDIT: solved. This is really weird. Within the folder of the page there’s a PDF file. This PDF has three associated metadata files, as there used to be a swiss version which is disabled for now. However kirby took the swiss metadata file of the PDF which was still there, appended de-de.txt for the german-Germany-version and used that as the content file?! All changes made in the panel were reflected in there. A first fix was to delete all PDF metadata files, which lets me fear that this problem will reoccur if I create them again.

Sounds similar to a problem I had: esp for the pages where the panel doesn’t save the changes anymore, can you check if you maybe got three content files now – page.txt, and page.en.txt?

Good idea, happened to me so often after enabling multiple languages… However in this case things were way weirder, see my edit above.

I had a similar problem recently where the metadata file of a renamed image was taken for a content text file:

I wonder if there is a way to prevent that happening, @bastianallgeier? Somehow exclude files that contain certain file extensions from being regarded as content files?