Getting started with Kirby

Hi there,

I’m new to Kirby and have installed PHP and MAMP on Mac. I can access the Kirby installation via localhost://8888/kirby however, I only see a list of files and folders in the browser. When I click on panel I only see files and folders. I downloaded the Kirby starter kit, extracted the files and copied the Kirby folder into the htdocs folder. Kindly let me know if that’s the way to go. Many thanks :slight_smile:

If you put all the files directly into the htdocs folder, the Starterkit should be accessible under localhost://8888, without the kirby path

Thank you for getting back to me. I copied all files that were inside the Kirby folder into the htdocs folder and typed localhost://8888 but I get a message saying that Safari cannot make a connection.

I use MAMP on my Mac and this is the message that shows in Safari after typing localhost://8888:

Willkommen bei MAMP

Wenn Sie diese Seite sehen, dann bedeutet dies, dass MAMP erfolgreich eingerichtet und gestartet wurde. Sie können jetzt Ihren Web-Inhalt hinzufügen, diese Platzhalter-Seite1 sollten Sie ersetzen bzw. löschen.

Server-Software: Apache/2.4.54 (Unix) OpenSSL/1.0.2u PHP/7.4.33 mod_wsgi/3.5 Python/2.7.18 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_perl/2.0.11 Perl/v5.30.1
Server-Name: localhost
Document-Root: /Applications/MAMP/htdocs
Protokoll: http
PHP 7.4.33

1 Datei: index.php

For the latest Starterkit, you need at least PHP 8.

When you say kirby folder, I guess you mean the complete contents of the Starterkit you downloaded, not just the kirby folder that was inside?

I put the folder Kirby inside the htdocs now and the following shows when I type localhost://kirby I see a list of the files

No, only the files inside the Kirby folder

You need to have the following files in your htdocs folder, the kirby folder alone is of no use:

That is, everything that was inside the starterkit folder you got when you unzipped the download.

Alight, I see. I just followed your instruction. I moved all the files inside the starter kit to the htdocs and typed localhost://8888 and I’m seeing the same message.

Which version of Mamp do you have, standard or Pro? And as I said above, you need PHP 8+, not 7.4.33 which is showing in the above message.

Also, make sure that you copied the .htaccess file.

I see, where do I find the .htaccess file?

It’s in the folder you downloaded. since it is a file with a prepended dot, it might not be visible by default.

You can toggle visibilty with CMD + Shift + .

Many thanks indeed. Everything went well. I apologize for the belated reply.

I’ve tried to install Kirby on my webhost but received the following message:

The panel cannot be installed
The panel installer is disabled on public servers by default. Please run the installer on a local machine or enable it with the panel.install option.

I only see " Try again"


Have you added the option I linked above to your config?

This is how I put it inside the config.php file:

<?php /** * The config file is optional. It accepts a return array with config options * Note: Never include more than one return statement, all options go within this single return array * In this example, we set debugging to true, so that errors are displayed onscreen. * This setting must be set to false in production. * All config options: */ return [ 'debug' => true, ]; return [ 'panel' =>[ 'install' => true ] ];

Looks like you have muliple retrun statements there

the whole file should look like…

return [
  // Debugging
  'debug' => true,
  'panel' =>[
    'install' => true