Field blueprints don't work

I have copied the tutorial exactly (for imageselect field)… doesn’t work. I get ‘invalid field type’.
I would like to be able to use this field many times in many blueprints… but no matter what I enter in the fields blueprint, or the page blueprint… it says “Invalid field type (“animate”)” (or any other name I give it… nothing works. What am i doing wrong?

One example:

label: Animation
type: select
default: none
  none: none
  fadeIn: fadeIn
  fadeInDown: fadeInDown
  fadeInDownBig: fadeInDownBig
  fadeInLeft: fadeInLeft
  fadeInLeftBig: fadeInLeftBig
  fadeInRight: fadeInRight
  fadeInRightBig: fadeInRightBig


#other stuff, then 'animations' is a tab name...
      animate: animate

Should be like that:

      animate: fields/animate

Extending format is DIRECTORY/FILENAME

Thanks. I tried that after finding it on another thread. It didn’t work. Same error.
I’ve given up and am using kirby.options and a query instead.

The only thing I can think of is that you have either a typo or an indentation error somewhere but since you’re only posting bits of your code is impossible to properly help you out.

I recreated your setup, with the animate.yml inside /fields and then reused inside a tab and as you can see everything is working as intended.

I’m happy to figure out what your problem is if you post your entire blueprint.