Structure fields in Site blueprint: unable to edit/add data

I’m unable to use the panel to add or edit entries in a structure field only inside Site options. It works perfectly on any other page of the site.

Given the following blueprint:

title: Site
    label: Foo
    type:  structure
    entry: >
      {{ bar }}
        label: bar
        type: text

Whenever I try to add or edit an entry the modal window fails to launch (I just see the dark overlay layer) and get the following error:

Fatal error: Uncaught exception 'Exception' with message 'Invalid route' in project/panel/app/panel.php:222 
Stack trace: 
#0 project/panel/index.php(47): Panel->launch() 
#1 {main} thrown in project/panel/app/panel.php on line 222

Things I’ve tried:

  • Create a simplified test-case (blueprint code above)
  • Disable multilanguage support in config.php.
  • Remove everything from config.php.
  • Delete site.php from the content folder.
  • Make sure Kirby, Toolkit and Panel are all up to date (2.1.0).
  • Try using a fresh clone of the Starterkit and Langkit: it works.

Anyone have any idea of what the problem is? Or how i can debug it further?

Same problem. Am using the latest versions of kirby and panel too. Any luck?

I suggest you do a fresh install and paste your content/assets/templates etc. into it. In my installations, structure fields in site settings do work.

Same problem here. I’ve tried kirby 2.1.1, 2.1.2 with panel/toolkit 2.1.1
To reproduce add this example to site/blueprints/site.php: (under fields:)

      label: Social Links
      type: structure
          label: FontAwesome Icon Name
          type: text
          label: Link Url
          type: url

Have you tried with version 2.2.3? It works in my current test installation.