Fallback on default blueprint when multi language is set

Hi there,

we have built a kirby theme with special blueprints and now want to start a site with multi language support.
I set up the language support as it is described, but now no blueprint is loaded to create my content.

I tried to give the en: and de: option for the labels etc in the blueprints, I tried to rename the blueprint like contact.en.php

Can anyone help?

Did you setup the configure too? http://getkirby.com/docs/languages/setup

I did the default setup without the detailed locale settings, set my default language to german

The blueprints should not have the language code. Have you made sure, you have no text files without language code in your page folders, that is, you have renamed the xyz.txt files into xyz.en.txt etc.

I also removed all content files before i set up the languages

Have you also made sure that the filenames are identical, i.e. if your text file is name xyz.en.txt, your blueprint is also called xyz.php (no mixture of capital, small letters etc)? Did this problem only come up after enabling multi-language support?

this problem came up after enabling multi-language support. I didn´t use camelCase or something…

Are there any meta files for images or something like that in those folders? In most cases, stray text files are the problem, if the default blueprint is loaded. Also, all filenames should be lowercase.

Other than that, have you tried to set the locale (although I don’t think that that is the problem).

Hi there,

I ran into a very similar problem. I created a multi-language site (english and german) with the default setting of english. Every time I create an page with an specific blueprint and switch the language mode to german I can only edited this page with the default blueprint and not the specific one I created. I don’t have any problems with blueprints in the default language setting (english) or whatsoever.

My multi-language setup is based on the offical guide and as I recollect every file is named xyz.en.txt. If I copy one file and change its name to xyz.de.txt everything is working correctly. But this is only a workaround.

Is there any solution for this kind of problem? Thanks :slight_smile:

Have you checked if there are any other text files in the page’s directory? Like one named xyz.txt (without language code) or a text file that belonged to a file that has now been deleted?

I checked for that. If I’m not mistaken, every .txt file is prefixed with a language code (xyz.en.txt and so on). I’m using version 2.3 of kirby and the panel but I don’t really know if this is valuable information regarding this issue.

It’s really strange to me why the panel only want to use the default blueprint for every panel, when I’m editing a page in the german language mode.

That’s a bit of a strange issue, I have never experienced that myself and unfortunately there is no feedback from the original thread opener if the issue was ever resolved. Do you experience the same issues with a clean langkit as well?

Did the issue only appear AFTER updating to 2.3?

What happens if you save such a file with the default blueprint? Does it get saved as default.de.txt?

I started this project only on 2.3. After downgrading to 2.2.3 and some basic testing it seems like this issue is related to 2.3 in some way. I’m going to look a bit more into this over the weekend.

Yes, this was the result.

Did you use the latest version of the Kirby 2.3 beta? Will try to look into this as well, so if this is some sort of bug, we should try to fix this before the final release.

I was able to reproduce this weird behavior with a clean langkit installation. If you delete project.de.txt and switch from en to de inside the panel, all the panel does is switch to the default blueprint instead of the specific project blueprint.

I tested this with kirby beta version from the Upcoming Page.

Thanks for testing. I have created an issue on GitHub.

I fixed this a couple days ago. Could you please make sure to get the very latest version of 2.3 from Github (core and panel) and try again?

After some basic testing I can say that this bug seems to be fixed. I didn’t have any trouble with the panel/multi language setup after the official 2.3 release.

Thanks :slight_smile: