Error when installing a new theme

Hello
I have started by installing the “Starter Kit” I messed around trying to add a blog, but was not having the success I hoped for.

Next I purchased an inexpensive theme that looked simple and clean. I tried to swap out folders staying in the same directory structure.

Now I get an error:

"
Error

session_start(): The session id is too long or contains illegal characters, valid characters are a-z, A-Z, 0-9 and '-,'
"
Can anyone give me some advice and how to solve the problem? Thank you for your time.

Try deleting the session data in /site/sessions.

texnixe
Support

    February 22

Try too delete the session data in /site/sessions.


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

@tsparks ?

The site\session folder was empty.

I wonder if the problem is the site initially was made with the starter kit? I first tried to do a fresh install with the theme but soon realized having kirby in a second location was illegal.

  • Have you been able to solve the problem?
  • Have you made sure to use a Kirby 3 theme?
  • You can also try to delete the session data in your browsers dev tools, that usually should solve the problem

Still working on the problem, I can open domain/panel without a password , I get redirected to domain/panel/install with the same error every time

I will try cleaning my browser.

Cleaning out the browser cleared the error. I get the panel now but Kirby doesnt recognize my license key.

Is this a syntax problem or do I need to do something else? Here is my config file:

<?php

# License
c::set('license' , 'K3-PRO-somemoreletters');

# Kirby Settings
c::set('debug' , true);


# Enable/disable adding images to XML Sitemap

c::set('sitemap.include.images'   , false);
c::set('sitemap.include.invisible' , false);
c::set('sitemap.ignored.templates' , ['feed']);

c::set('panel.install', true);

return [
  'panel' => [
    'slug' => 'panel'
  ]
];

That is old Kirby 2 code. You have to register your K3 license via the panel, in the Startpage of the Panel you will see a Register button:

04

If you click on that, you can enter your license code.

Adding your license in the config.php won’t do anything.

Where does that old config code come from? Are you updating from Kirby 2?

Yes I did update from Kirby 2 . I do not see the key like your image shows. Do I need to re-install to get to the version 3? The maker of the theme said it was a Kirby 3 theme. Below is my setup.

Kirby info

Toolkit version: 2.5.12
Kirby version: 2.5.12
Panel version: 2.5.12

Kirby license

You are using the Kirby trial version
Please, buy a license ›

But that is a Kirby 2 installation, not a Kirby 3 installation. What is the theme you bought, could you provide a link, please?

Something seems to be pretty messed up.

Please don’t jump to conclusions I could have created these problems myself by mixing code from 2 and 3.

The theme came from : https://manuelmoreale.com/ he sells via this site:

He has been friendly and helpful I don’t want my problems to be his problem. I am not too skilled at this and could easily messed this up myself.

I think maybe I should go through the upgrade instructions again see if that sorts this out.
https://getkirby.com/docs/cookbook/migration/sites#requirements-and-installation

No, I’m not jumping anywhere, I just wanted to try and clarify what’s happening here.

Did the theme come with the Kirby core files?

image

That’s the folder structure I recieved.

That’s definitely Kirby 2, not Kirby 3. Kirby 3 doesn’t have a panel folder on the root level, nor a thumbs folder.

I think you best get in touch with @manuelmoreale and ask for the Kirby 3 version, probably the link hasn’t been updated yet.

Will do thank you!

@tsparks sent you an email :wink:

Manu, Sonja

Thank you for your patience, everything is working as it should. I am happy and grateful. Have a wonderful weekend!

Glad you could sort it out!

Have a great weekend, too, @tsparks .