Disable multilingual setup

I’m working on a website that previously had a multilingual installation of Kirby. Trying to do everything in english now so I want to disable multiple languages. I’ve removed them from the languages folder and changed the config file input to: ‘languages’ => false.

In the browser the site keeps redirecting to /en which works fine but is ugly when there’s just one language. I figure it’s because each page and media have .en.txt in their name. Is removing that going to solve the problem and is there a way to do a batch replace? Or is there a different solution?

Did you change the lang config file as well? Each language has its own config file, they reside in /languages

You might have to delete language config files in /languages/

It would have been better if you had let the Panel take care of it. Once the language files are removed, Kirby will not recognize the language extensions in the content files anymore.

If you remove the languages via the Panel, Kirby takes care of renaming the content files.

You have two options now:

  1. Re-add the language files you removed and then do it again via the Panel
  2. Rename all content files manually and remove the ones for the no longer existing languages

Thank you this fixed it. I changed the languages back to true in my config file and deleted the language. Now everything works the way it should:)