Changes not saving properly- blueprint issue

Hi there, I’ve been working with a folder for quite some time, and it has been functioning normally for two weeks until today.

It has three subpages that are usually visible with 1-foldername and so on under the content folder. But today, the subpages were changed to invisible and an hyphen was added to the subpages’ names. The subpage name looked like -foldername.

I tried changing the URL of all subpages, removing the hyphen (-), and I tried making all the subpages visible via Panel. It would only work for about 15 seconds, then the folder structure would revert to invisible for all subpages and the hyphens would appear again in front of all of their names.

I deleted the subpages and tried creating them from scratch, and now the problem has only gotten worse- it now shows all subpages as --foldername. None of the pages can be made visible, and their URLs can not be changed.

Can anyone let me know if there is a solution? Thanks!

That sounds extremely weird! Which version of Kirby do you use? Do you have any cronjobs running? There’s no automatic stuff going on in the panel in the background, so I have no idea why folders would change just like that.

I had something like that a while ago. Found out that I used a field with name “update” or something like that which is used by a core function. Each time I saved the file in panel something weird happend.

Dunno if this is something similar on your end.

Took me a while to find that :slight_smile:

@aftereffectsmagic You marked your topic as solved, would you mind telling us how you solved the problem in case someone else encounters something similar? Thanks!

Thanks for the replies, @bastianallgeier, @ik_arno and @texnixe!

This issue was so odd that I went back to my blueprint and redid it from scratch, ensured that there were no spacing issues or character issues, and removed any fields with underscores or hyphens in their names. I never did find a specific error in my blueprint, but by typing it up again, I was able to fix this issue.

If you are experiencing this issue:

  1. Delete all subpages in that particular folder
  2. Create a new blueprint that you want to use for those subpages, make sure there are no underscores ( _ ) or hyphens ( - ) in the field names and make sure everything is properly and consistently spaced
  3. Recreate the subpages again using the new blueprint
  4. The problem should disappear after all the subpages are created.

Obviously, this solution wouldn’t be ideal for a large number of subpages, but in this case, I only had three- so it wasn’t a major deal to recreate the subpage structure. Clearly, the approach I outlined above is not an ideal large-scale solution for this issue.

This may be tangentially related to the same issue @mzur created in Github here, where he describes our conversation about allowing ’ _ ’ as a valid string for field names.

Hope this explanation helps!