Changed permissions - now entire site is 404 :(

Man, this is totally going to ruin my ‘new user of the month’ cred… sob

[UPDATE: I’m going to take part of this and create a new, separate post]

So I have been setting up micropub. I managed to get OwnYourGram to post some test pictures from my Instagram account to my blog, but with errors. When I looked in the panel, the posts were there, the pictures were added, but were not in the ‘cover photo’ field. They were also not in the articles in any way, and no photos were visible on the blog, just comment text.

So I looked at the Pi via SSH and the user and group were both set to pi. I manually changed the folders and files to pi:www-data then I looked further into permissions and started mucking around, doing a lot of site-wide permissions changes. The next time I tried to access my site in the browser I got just 404.

I have since attempted several permissions fixes, both chown and chmod. So far nothing has changed and the entire site is still offline.

I’m hoping this is an easy fix, typical newbie mistake? Any ideas?

So what’s worse? Having this issue, or posting about it before I try to reboot my server?


Yeah, it totally works fine now…

Did you know we have a “Solved” category? it is nice and gray…:wink:

I’ve been wondering how to do that! Thanks :slight_smile: