Can't activate Panel

Hello all,

I can’t activate the panel online.

Here’s the message :slight_smile:
You are only allowed to run the panel installer on a local machine or by
setting the option panel.install to true in your

When i try to write the licence in the config file, then the screen is empty when i connect to panl. Any idea what happens ?

1984hosting is my host.

Yes, it’s a new security feature that was added in Kirby 2.3.0.

To be able to install the Panel, include this line in your config.php:

c::set('panel.install', true);

Make sure to delete this line again after you have created your first Panel user.

Thanks it worked.
But the licence problem stille exists…

If the screen is completely blank, you probably have a syntax error, maybe a missing semicolon at the end of a line? Or missing quotes? Pls. turn on debugging in your config.php to be able to see such errors:

c::set('debug', true);

I tried it but it is still blank even with the debug.

Pls. check your php error logs. I’m pretty sure this is a syntax issue. If there is nothing in the logs, pls. post your config.php but replace the license with some arbitrary numbers.

There was an error in the code that @texnixe posted above. I have corrected that. Could you please try again?

Log is empty…



License Setup


c::set('license', ‘K2-PERSONAL-xxxxxxx’);
c::set('debug', true);

Kirby Configuration

By default you don't have to configure anything to
make Kirby work. For more fine-grained configuration
of the system, please check out


The quotes in the license line are incorrect, they need to be the following:

c::set('license', 'K2-PERSONAL-xxxxxxx');

Okay thanks, they are the one in the standard file.
Swift answers !
thanks for your time.

You are welcome. :slight_smile:
Just out of interest: Where did you get the other quotes from? Maybe something in the docs is incorrect.

They are the ones to fill in in the standard download from Kirby website.
Reason why my panel.install didn’t worked too. I had copied the same line and changed the commands.
I don’t code…

But the file in the download uses “normal” quotes, doesn’t it? Maybe I have misunderstood.

Which software on which OS do you use to edit the config.php file?

It was iawriter… It is very possible the qotes were changed by it.