Writer toolbar not working in blocks inline

Since updating to Kirby 4 the Writer toolbar doesn’t work on my blocks within my panel. It appears but when I click on anything (Bold, Link etc) the toolbar disappears and nothing happens.

However, the toolbar does work when I click the block’s pencil icon (in the drawer area) and I edit the content this way.

This used to work in Kirby 3 fine.

I am using Kirby 4.01

I tried to reproduce it but couldn’t. Could you please post the blueprint/preview of your custom block?

Its just a Text block which I have changed the blueprint to the following below. I have not edited the preview.

name: field.blocks.text.name
icon: text
wysiwyg: true
preview: text

        type: writer
        nodes: true #changed from default
        placeholder: field.blocks.text.placeholder
        label: Preset Styles
        type: select
        width: 1/4
        alowempty: true
          larger: Larger Font
          serif: Serif Font
          larger serif: Larger + Serif Font

        label: Preset Colour
        type: select
        width: 1/4
        alowempty: true
          plum: Plum
          plum-dark: Plum Dark
          plum-pale: Plum Pale
          pink: Pink
          mint: Mint
          yellow: Yellow
          white: White

        type: toggles
        label: Alignment
        width: 1/2
        allowempty: true
          - value: text-start
            text: Left
            icon: text-left
          - value: text-center
            text: Center
            icon: text-center
          - value: text-end
            text: Right
            icon: text-right

  styles: fields/settingsColumn

I now tested this with your block as well, and still cannot reproduce it.

Could you please try and delete the media folder and the browser cache and check if that changes anything?

Have you also tried another browser (what are you using?)?

It appears to just be happening on Safari on my mac. Strange why this changed from Kirby 3 to Kirby 4?

Maybe this is related: [v4] nodes in writer field not accessible in Safari · Issue #5442 · getkirby/kirby · GitHub

Sounds just like the issue I am having - Glad it’s not something I have done for once.