URL images doesn't work anymore


I’ve to make some correction on a client website. I had dowload all the website from the server where i put it 3 month ago. When I’m trying to run it locally, the images and some plugin doesn’t work, I’ve some 404 error messages that would signify I can’t find this files, but when I’m looking the path, it’s seems good.

I’m completly lost what can be wrong.

this is the page working online

and this is what I’ve when I run it locally…

Have you made sure to delete all files/folder in the /media and site/sessions folders? The after you have done that, check if files get created as expected in the /media folder.

It’s doesn’t change anything

Check your folder/file permissions.

Do images actually get created in the media folder?
Do subpages work and the Panel?
Did you also download the .htaccess file?
What is your development environment?

I had change the folder/file permissions.

When I delete all the folde in /media and site/sessions nothing is created.

I’ve got the .htaccess file.

I’m working on Ubuntu 18.04.3 LTS, I’m under PHP 7.2.12 version.

When you first created the project, did it work then?

Could you please answer my other questions from above, if subpages work or the .htaccess file is maybe completely ignored.

I’m assuming you are on Apache not another type of server…

Yes it worked when I created it (4 month ago) and it’s working online.
But since 2 days the original project and the downloaded ones doesn’t work anymore…

When I’ve deleted the folders you sayed, subpages doesn’t work and I’ve got some trouble with the Panel (I’ve missed some plugin and I can’t save au page)

I’ve got the .htacces in the both project.

Yes I’m running Apache server.

I hope, I have answe your question,

Thanks for the attention

If subpages don’t work, then maybe the .htaccess is either ignored or you changed something. Could you please post the .htaccess.

# Kirby .htaccess

# rewrite rules
<IfModule mod_rewrite.c>

# enable awesome urls. i.e.:
# http://yourdomain.com/about-us/team
RewriteEngine on

# make sure to set the RewriteBase correctly
# if you are running the site in a subfolder.
# Otherwise links or the entire site will break.
# If your homepage is http://yourdomain.com/mysite
# Set the RewriteBase to:
# RewriteBase /mysite

# In some enviroments it's necessary to
# set the RewriteBase to:
# RewriteBase /

# block files and folders beginning with a dot, such as .git
# except for the .well-known folder, which is used for Let's Encrypt and security.txt
RewriteRule (^|/)\.(?!well-known\/) index.php [L]

# block text files in the content folder from being accessed directly
RewriteRule ^content/(.*)\.(txt|md|mdown)$ index.php [L]

# block all files in the site folder from being accessed directly
# except for requests to plugin assets files
RewriteRule ^site/(.*) index.php [L]

# Enable authentication header
SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1

# block direct access to kirby and the panel sources
RewriteRule ^kirby/(.*) index.php [L]

# make site links work
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php [L]


# compress text file responses
<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE text/javascript
AddOutputFilterByType DEFLATE application/json
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript

If you put any random characters into the .htaccess, do you get an error?

I don’t get error…

Ok, then your .htaccess is simply ignored. You have to make sure in your server config that .htaccess overrides are allowed.

Thank’s, I will take a look.

I made some change on my local server during this summer, and I’m kind of novice at it.

Thank’s for your attention