Uniform Error on Send - The validator does not exist

Created a form in using Uniform that worked fine when using the example, but when editing the fields it’s now causing errors. Any guidance regarding this would be superb.

The validator does not exist:
        // check for missing validators
        if (isset($validators[$method]) === false) {
            throw new Exception('The validator does not exist: ' . $method);

This site is still in development but you can try the form and see there error here: https://suljam.com/contact Thank you


Would be more interesting to see your controller.

On a side note, your labels should have a for attribute… so it is clear to which input field each label belongs.

1 Like

All working now after adding the for attributes which is weird as it worked before without them :confused:

Thank you @texnixe as always!

From an accessibility standpoint, you shouldn’t leave out the for attribute ever.

I know, I was just quickly testing mainly and didn’t think it would break the process.