Ubuntu 20.04.1 LTS openlitespeed and PHP requirements

Hi,

I’m having a bit of a hard time figuring out the requirements with the openlitespeed web server. From the Kirby requirements these PHP modules are required:

  • mbstring extension
  • curl extension
  • ctype extension
  • gd extension

Only curl exists for the official openlitespeed repo. http://rpms.litespeedtech.com/debian/dists/focal/

Has anyone else solved this? How did you go about it?

Cheers,
Martin

Wouldn’t this be rather a question to any openlitespeed forum, if this (https://openlitespeed.org/kb/php-via-rpm/) doc does not help?

Well, thought people here might have had this specific issue too.

Thanks! The EPEL repo is worth exploring.